Club Chopper Forums ychrome  

Go Back   Club Chopper Forums > CHOPPER SHOP/TECH AREA > Shop Talk > Technical Guides, Information, Resources & Data

Welcome to Club Chopper!  The World's largest and coolest place to be on the net if you dig the following!

  •  » Custom Bikes
  •  » Killer Paint
  •  » Old School Craftsmanship
  •  » Building and Wrenching
  •  » Hot Babes
  •  » Chopper Build Logs

...then you have come to the right place!

YES! I want to register an account for free right now!  p.s.: For registered members this ad will NOT show

Chopper Tech
Tech Article
Tech Article
Tech Article
Tech Article
Tech Article
Main Menu
Module Jump:
Club Chop Gallery

Club Chopper Gallery

Submit Your Photos!

Active Threads
Tappet block oil problems
Last Post: michelinesander
Posted On: 01-28-2024
Replies: 2
Views: 7,947
Powder coating
Last Post: pushrod243
Posted On: 01-15-2024
Replies: 1
Views: 7,539
revtech 100 starts then dies
Last Post: mabelhillhouse
Posted On: 01-03-2024
Replies: 1
Views: 7,146
Hello guys
Last Post: mabelhillhouse
Posted On: 01-03-2024
Replies: 0
Views: 5,190
5 speed clutch
Last Post: mabelhillhouse
Posted On: 01-03-2024
Replies: 1
Views: 7,312
More...
  #1 (permalink)  
Old 11-08-2023, 03:07 PM
Junior Member
Visit my Photo Gallery
 
Join Date: Nov 2023
Location: Lincoln, Ca
Posts: 1
Not Ranked     
revtech 100 starts then dies

Hello everyone,new to the Forum,New to choppers👽
My name is Rick
I have an 07 Big Bear Pro Street Sled
Revtech 100 motor
As long as Ive had it(Bought it not running)when it ran there was always a little backfire here and there, nothing extreme, it wouldn't kill it but didn't feel right. Ive been riding my whole life but never choppers.No idea what to expect.
So Ive had it parked for a couple months and now it starts but just dies.
If I keep working the throttle it will run , But poorly.
It is running super rich, fouling plugs
I have taken the carburetor apart and cleaned everything out ( Mikuni hsr42)
Compression is 140 rear 135 front
There's also something else that is strange, the gas cap is locked in to the tank
I had just changed the o-rings and gave it a little lube
Its the kind that pops up
Anyway,hello,nice to meet you and if ya got any clues I would be most grateful !😉
Reply With Quote
Sponsored Links
Sponsored Links
  #2 (permalink)  
Old 01-03-2024, 02:22 AM
Junior Member
Visit my Photo Gallery
 
Join Date: Jan 2024
Location: Arlington Heights, IL
Posts: 3
Not Ranked     
Hello, if the engine is running too rich, it could result in poor performance and fouling of spark plugs.


Last edited by mabelhillhouse; 01-04-2024 at 06:08 PM..
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -7. The time now is 10:20 AM.


vBulletin skins developed by: eXtremepixels
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0

CC Policy

The representations expressed are the representations and opinions of the clubchopper.com forum members and do not necessarily reflect the opinions and viewpoints of the site owners or moderators. clubchopper.com forum members agree not to post any copyrighted material unless the copyrighted material is owned by you or have been given the expressed written consent to post. Although we do not and cannot review the messages posted and are not responsible for the content of any of these messages, we reserve the right to delete any message for any reason whatsoever. You remain solely responsible for the content of your messages, and you agree to indemnify and hold us harmless with respect to any claim based upon transmission of your message(s). For full policy, please click the "CC policy" link. Thank you for visiting the clubchopper.com
Links monetized by VigLink