Club Chopper Forums ychrome  

Go Back   Club Chopper Forums > CHOPPER SHOP/TECH AREA > Shop Talk

Welcome to Club Chopper!  The World's largest and coolest place to be on the net if you dig the following!

  •  » Custom Bikes
  •  » Killer Paint
  •  » Old School Craftsmanship
  •  » Building and Wrenching
  •  » Hot Babes
  •  » Chopper Build Logs

...then you have come to the right place!

YES! I want to register an account for free right now!  p.s.: For registered members this ad will NOT show

Chopper Tech
Tech Article
Tech Article
Tech Article
Tech Article
Tech Article
Main Menu
Module Jump:
Club Chop Gallery

Club Chopper Gallery

Submit Your Photos!

Active Threads
4 -NEW S&S COMP. Rleases
Last Post: maddmaxxx
Posted On: Yesterday
Replies: 0
Views: 16
What starter and battery for my Ultima 127"
Last Post: Zlogonje Dan
Posted On: Yesterday
Replies: 16
Views: 602
wiring question - connectors?
Last Post: jgs348
Posted On: Yesterday
Replies: 5
Views: 105
Hellion CFL Build.
Last Post: flysocal77
Posted On: Yesterday
Replies: 305
Views: 30,410
More...
  #1 (permalink)  
Old 08-02-2011, 12:39 PM
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Jul 2011
Location: Marysville, Oh
Bike Year, Make, Engine: 2004 Texas Chopper
Posts: 48
Not Ranked     
Question 2004 Texas Chopper falls flat when crack throttle?

I have a 2004 AHI Texas Chopper with the 111ss and super g carb.When I take it easy runs fine , had been sitting not ridden much last 4 years. Drained gas , cleaned carb bowl and I had taken jets out cleand them put back together no sputtering. Everytime I crack the throttle it sputters if I take it for a normal ride does fine when I try to get into it just falls all over? Putt new fuel filter on ran some seefoam through it new plugs and wires cleaned air filter. Before I cleaned jets it would start sputtering at cruising speed , cleaned jets cruises good but cant crack the throttle to fast or it just falls flat until I back off. Bike has 4900 miles not sure where to go now carb, ignition ? Or somwhere else? Any help would be great! Also wondering about the aluminum petcock freezes up when it gets hot is there a fix or need to go to a different petcock? Or just leave on when riding? works fine when it cools off!
Thanks Harley0441
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 08-04-2011, 08:06 AM
Ricky-D's Avatar
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Jan 2007
Location: W.Columbia, SC
Posts: 2,997
Not Ranked     
I think the accelerator pump is not working.

Clean it up and/or replace it.

***
Reply With Quote
  #3 (permalink)  
Old 08-04-2011, 08:16 AM
RedWings's Avatar
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Jun 2008
Location: South Texas, TX
Bike Year, Make, Engine: chopped hardtail 100"Evil Evo
Posts: 7,993
Not Ranked     
+2 on that, that petcock should NEVER get that hot.
__________________
Just tryin to make it in this fuked up world without gettin busted for some bullshit thing
Reply With Quote
  #4 (permalink)  
Old 08-04-2011, 08:17 AM
RedWings's Avatar
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Jun 2008
Location: South Texas, TX
Bike Year, Make, Engine: chopped hardtail 100"Evil Evo
Posts: 7,993
Not Ranked     
+2 on that, that petcock should NEVER get that hot, you get few air bubbles in there and its melt down time.
__________________
Just tryin to make it in this fuked up world without gettin busted for some bullshit thing
Reply With Quote
  #5 (permalink)  
Old 08-04-2011, 07:14 PM
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Jul 2011
Location: Marysville, Oh
Bike Year, Make, Engine: 2004 Texas Chopper
Posts: 48
Not Ranked     
Thanks for the replys I will play with the carb some more. Read some other post and called Charles at Huntsville Ironhorse and he told me the petcock reacts to the heat from the temp and motor heat , said AIH made a replacement for the aluminum petcock that sells for $245. Said they would have replaced it for free way back when. Have to say this site has been awsome!!! Thanks again for the replys. Had a Harley just worked a trade for this Texas Chopper, it only has 4700 miles and 700 of those since 09 . I figured it was the carb, the filter and carb was filled with so much stuff I figured I still had some bugs to work out. Just needed some reassurance. Thanks again
Harley0441
Reply With Quote
  #6 (permalink)  
Old 08-16-2011, 01:06 PM
pjb pjb is offline
Club Chopper Member
Visit my Photo Gallery
 
Join Date: May 2004
Location: southern, MD
Bike Year, Make, Engine: 2005 AIH LSC
Posts: 337
Not Ranked     
petcock is made by Golan, and they do have a newer model that doesn't lock up. Falling flat when you crack into it could be accelarator pump adjustment, as mentioned. S&S has real good carb tuning instructions on their website. Is it the stock air cleaner?
__________________
PJB
2005 LSC
1985 Wide Glide
Reply With Quote
  #7 (permalink)  
Old 08-16-2011, 03:35 PM
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Jul 2011
Location: Marysville, Oh
Bike Year, Make, Engine: 2004 Texas Chopper
Posts: 48
Not Ranked     
I think it has a KN airfilter it's not foam like I had on a previous SS, I was also wondering about the battery, I was out the other day and started to get into it and it Seamed like I lost power, speedodometer went dimm if I put hand over it could see it but in sunlight it was dimm.Never had this problem before.could always read everything fine in any type of light so I'm wondering if I am having electrical issues? I haven't made any adjustments to carb yet but when I started to get into it it was like I lost all power so I'm kinda stumped gas or electrical? Not sure where to start been kind of short on time . Will play around with it this weekend some more but any suggestions would be greatly appreciated! I'm hooked onthis site it has the most info on the Ironhorse I have found yet! Awesome forums,galleries and so much more! Not to far from Dayton area so hope to eventually run into Orange Skulls sometime sweet ass ride you have!!!
Harley0441
Reply With Quote
  #8 (permalink)  
Old 08-17-2011, 03:51 AM
pjb pjb is offline
Club Chopper Member
Visit my Photo Gallery
 
Join Date: May 2004
Location: southern, MD
Bike Year, Make, Engine: 2005 AIH LSC
Posts: 337
Not Ranked     
loose connections at the battery terminals will definitely cause problems like you are having. seen it happen several times. also make sure the battery isn't moving around. I've seen the positive terminal short to the frame.
__________________
PJB
2005 LSC
1985 Wide Glide
Reply With Quote
  #9 (permalink)  
Old 08-17-2011, 12:27 PM
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Oct 2007
Location: Hartville, OH
Bike Year, Make, Engine: 2004 Texas Chopper 111 S&S
Posts: 35
Not Ranked     
04' AIH Chopper

Hi,

I have a 04' Texas Chopper too - this is my fourth summer. I had my petcock replaced with the newer 'non-locking' version and it works fine. I do not like how the tank is split inside and SOMETIMES I forget if I'm on reserve or not as both sides can serve as your gas reserve.

As to the speedo dimming: there is a self-dimming in these things - so under bright sun it lowers the illumination?!?!? And at night it is brighter then.

The falling off on the throttle could be the accelerator pump and that little black round rubber gasket / seal inside the carb - make sure it seats properly or get a rebuild kit replacement. It also could be the piece of crap Gill ignition system - I've had so much trouble - just like you - falling off, loss of power, one cylinder firing....... This past spring I bought the Daytona Twin Tec module made just for our bikes. Got it on Ebay for a good price. What a ****ing difference. My S&S 111 screams like a raped-ape now!!!!

Hope this helps.

Bill Vincent
Hartville, Ohio
Reply With Quote
  #10 (permalink)  
Old 08-17-2011, 04:21 PM
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Jul 2011
Location: Marysville, Oh
Bike Year, Make, Engine: 2004 Texas Chopper
Posts: 48
Not Ranked     
Talking

Info was great kinda had my doubts about my ignition system, have read a lot of post about electrical problems. Would you happen to remember what module you put on as far as part numbers? I'm going to do some tuning on the carb but might just go ahead and swap out the ignition haven't seen anything good about the one that's on it now.I love the bike just have to work out all the bugs.I have only put around 150 miles on it so far but will be doing a ride on the 27th out of Zainsfield Ohio , usually has couple 100 bikes one of the stops is at a Drag strip 5.00 for a couple runs timed down the strip $100.00 for the fastest time of the day have to tell ya pretty damn funny some of the shit guys will do for a $100 bucks , not sure where your located but would like to meet some other chopper guys. Look it up it's called the Rob Hayden memorial run thanks again for your info!! Thanks Harley 0441
Reply With Quote
  #11 (permalink)  
Old 08-17-2011, 05:07 PM
Orange skullz's Avatar
CC Member/Contributor
Visit my Photo Gallery
 
Join Date: Mar 2005
Location: Troy, OH
Bike Year, Make, Engine: 04' TEXAS CHOPPER 124ci.
Posts: 7,625
Not Ranked     
The Daytona Twin-Tec is the TC88A-IH ignition, specifically for 2004-07 American Ironhorse bikes.

The Gill ignitions are not a great piece and they are also NOT adjustable. I haven't had any issues with the stock one "yet", but it will get swapped at the first sign of trouble. I too have heard that the Twin-tec ignition will "wake up" what is already a damn good running bike.

....and yeah, we'll have to hook-up sometime. I'm in Troy...about 8 miles north of I-70,
__________________
Someone's full of SHIT....
Reply With Quote
  #12 (permalink)  
Old 08-17-2011, 06:16 PM
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Jul 2011
Location: Marysville, Oh
Bike Year, Make, Engine: 2004 Texas Chopper
Posts: 48
Not Ranked     
Talking

sweet thanks, your bikes baddasss !!! Im about an hour from Troy I heard about a place down your way called Jack Ass flat you ever been? Love your paint , You seem to be the man when it comes to AIH! i have been reading you replys and have learned more from you than anywhere on the web about AIH choppers. I have to say again this place rocks!!!!!Hey gotta music question for ya , I gotta guy wanting trade a fender strat for some bike parts , I have $600.00 on the parts guy said he was money poor wants to trade I dont know shit about guitars does that sound like a trade? The guy is actually in Cinci suppose to hook up with him this weekend to take a look at a set off tins I have. Did you hit the Crue when they were in Cinci? Was checkin out your Gallery Nice!!!!!!!!
harley0441
Reply With Quote
  #13 (permalink)  
Old 08-17-2011, 06:17 PM
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Jul 2011
Location: Marysville, Oh
Bike Year, Make, Engine: 2004 Texas Chopper
Posts: 48
Not Ranked     
And thank you WCV111
Reply With Quote
Sponsored Links
  #14 (permalink)  
Old 08-17-2011, 06:23 PM
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Jul 2011
Location: Marysville, Oh
Bike Year, Make, Engine: 2004 Texas Chopper
Posts: 48
Not Ranked     
Thanks,
Orange Skullz You the Man!
Reply With Quote
  #15 (permalink)  
Old 08-18-2011, 02:18 PM
Orange skullz's Avatar
CC Member/Contributor
Visit my Photo Gallery
 
Join Date: Mar 2005
Location: Troy, OH
Bike Year, Make, Engine: 04' TEXAS CHOPPER 124ci.
Posts: 7,625
Not Ranked     
Yep, been to Jackass Flats quite a few times, its about 15 minutes from me. Haven't been there this year though, to much other shit goin' on. Wednesday night is their "Bike night", but they get a decent crowd on friday's & saturdays also.

As far as the Fender Strat....they make MANY different models, that vary in price from $400 up to $2500. So it just depends what "model" he has.

And yep, did The CRUE show in Cincinnati (June 26th) and the one in Columbus (August 2nd) which made it Motley show #25 for me.

Sixx actually pulled my 7 year old son up on stage with him in Cincinnati, asked him a few questions and had him say "Motley Crue" in the mic....he was fuckin' pumped, LOL!!


__________________
Someone's full of SHIT....
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -7. The time now is 01:28 AM.


vBulletin skins developed by: eXtremepixels
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0

CC Policy

The representations expressed are the representations and opinions of the clubchopper.com forum members and do not necessarily reflect the opinions and viewpoints of the site owners or moderators. clubchopper.com forum members agree not to post any copyrighted material unless the copyrighted material is owned by you or have been given the expressed written consent to post. Although we do not and cannot review the messages posted and are not responsible for the content of any of these messages, we reserve the right to delete any message for any reason whatsoever. You remain solely responsible for the content of your messages, and you agree to indemnify and hold us harmless with respect to any claim based upon transmission of your message(s). For full policy, please click the "CC policy" link. Thank you for visiting the clubchopper.com
Links monetized by VigLink