Club Chopper Forums Industrial Parts House  

Go Back   Club Chopper Forums > CHOPPER SHOP/TECH AREA > Shop Talk

Welcome to Club Chopper!  The World's largest and coolest place to be on the net if you dig the following!

  •  » Custom Bikes
  •  » Killer Paint
  •  » Old School Craftsmanship
  •  » Building and Wrenching
  •  » Hot Babes
  •  » Chopper Build Logs

...then you have come to the right place!

YES! I want to register an account for free right now!  p.s.: For registered members this ad will NOT show

Chopper Tech
Tech Article
Tech Article
Tech Article
Tech Article
Tech Article
Main Menu
Module Jump:
Club Chop Gallery

Club Chopper Gallery

Submit Your Photos!

Active Threads
oil stained chrome pipes
Last Post: STEINBVG
Posted On: Today
Replies: 5
Views: 81
Finished Seats
Last Post: POVERTY
Posted On: Yesterday
Replies: 328
Views: 62,822
starter problem
Last Post: rem hamilton
Posted On: 11-20-2019
Replies: 6
Views: 270
Swing Arm bushings question
Last Post: Spade115
Posted On: 11-18-2019
Replies: 4
Views: 205
Ultima Fat Bastard
Last Post: Timfromflorida
Posted On: 11-16-2019
Replies: 11
Views: 4,261
More...
  #136 (permalink)  
Old 04-09-2007, 06:57 PM
BOSS's Avatar
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Mar 2004
Location: London, ON
Bike Year, Make, Engine: 05 Custom - Omen II
Posts: 2,003
Not Ranked     
Quote:
Originally Posted by Stynie
I asked cause I've been thinking. One of the times I changed the seal, I took it out for an easy ride and it didn't leak until the next when I had done a few holeshots. So maybe it is a pressure issue as some have mentioned.....maybe.

could be...but a 127" engine and much good if i cant use it!!!
__________________
Canada's Chopper Kingpin, Customs Guru, Pimp Daddy, & all around BAD MUTHA FUCKER !!!! ~~ GETTIN' JACK'T !!
Reply With Quote
Sponsored Links
  #137 (permalink)  
Old 04-09-2007, 07:01 PM
Stynie's Avatar
CC Member/Contributor
Visit my Photo Gallery
 
Join Date: Mar 2004
Location: Indian Trail, NC
Bike Year, Make, Engine: 80 FLH Shovel,74 93" Rigid Shovel
Posts: 1,103
Not Ranked     
Someone mentioned that EBOC or whatever he called it in an earlier post for venting the case. Maybe you should give Ultima a call.
__________________
Reply With Quote
Sponsored Links
  #138 (permalink)  
Old 04-09-2007, 07:04 PM
Stynie's Avatar
CC Member/Contributor
Visit my Photo Gallery
 
Join Date: Mar 2004
Location: Indian Trail, NC
Bike Year, Make, Engine: 80 FLH Shovel,74 93" Rigid Shovel
Posts: 1,103
Not Ranked     
Quote:
Originally Posted by dave19
I talked to Ultima and they have a product called an EBOC. It is a lower end breather. I installed one on my 127" but not enough miles on it yet to tell if it works. I figured it can't hurt. Sounds like you have a pressure problem if it leaks after a while once it builds up pressure.
this thing
__________________
Reply With Quote
  #139 (permalink)  
Old 04-10-2007, 06:31 AM
BOSS's Avatar
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Mar 2004
Location: London, ON
Bike Year, Make, Engine: 05 Custom - Omen II
Posts: 2,003
Not Ranked     
bump for the morning.....

picked up some o-rings and gonna grab a couple new seals and sleeve today if its in stock......any thoughts on putting 2 seals in...is that possible ??
__________________
Canada's Chopper Kingpin, Customs Guru, Pimp Daddy, & all around BAD MUTHA FUCKER !!!! ~~ GETTIN' JACK'T !!
Reply With Quote
  #140 (permalink)  
Old 04-13-2007, 04:58 PM
Stynie's Avatar
CC Member/Contributor
Visit my Photo Gallery
 
Join Date: Mar 2004
Location: Indian Trail, NC
Bike Year, Make, Engine: 80 FLH Shovel,74 93" Rigid Shovel
Posts: 1,103
Not Ranked     
Finally got to test my bike out today, and it seems I have finally stopped the leak . I used an o-ring behind the spacer and vented the case. I'm really not sure what fixed it, but right now I couldn't really give a shit...IT'S FIXED!! For the vent, I pulled out the plug next to the oil pump and connected a 4" piece of 5/16" hose curved straight up to a small breather which is just zip tied to the closest oil line. Picked up the fitting at Lowe's for the connection. There does not appear to be any oil visible at the breather either, and I did run it pretty hard too. Boss I hope this helps you, if you haven't fixed yours yet. Thanks to all for the suggestions. Eric
__________________
Reply With Quote
  #141 (permalink)  
Old 04-13-2007, 06:04 PM
Stynie's Avatar
CC Member/Contributor
Visit my Photo Gallery
 
Join Date: Mar 2004
Location: Indian Trail, NC
Bike Year, Make, Engine: 80 FLH Shovel,74 93" Rigid Shovel
Posts: 1,103
Not Ranked     
Check that. Still leaking. Not as big of a puddle as before and took a while to start dripping. Going to tear it down right now.
__________________
Reply With Quote
  #142 (permalink)  
Old 04-13-2007, 06:27 PM
Stynie's Avatar
CC Member/Contributor
Visit my Photo Gallery
 
Join Date: Mar 2004
Location: Indian Trail, NC
Bike Year, Make, Engine: 80 FLH Shovel,74 93" Rigid Shovel
Posts: 1,103
Not Ranked     
Found the problem. The bottom most stator bolt is leaking. Must be drilled too deep. Previous times I have used permatex on the bolts, but not this time(don't ask). Judging by the amount of oil and how long it took to drip this time, I think this time was a different issue than last few times(fingers crossed). Anyone know what would be the best sealant for this problem?
__________________
Reply With Quote
  #143 (permalink)  
Old 04-13-2007, 06:28 PM
Mr Scary's Avatar
Super Moderator
Visit my Photo Gallery
Lifetime Contributor  
Join Date: Aug 2005
Location: Behind the curtain, OZ
Bike Year, Make, Engine: Some kind of big ass V2, Alcohaulin' Ass
Posts: 35,570
Send a message via ICQ to Mr Scary
Not Ranked     
Dude!!!!!!!!!!!!

I told you about that!!!!!!!!!!!!!!!!!! LOL LOL

Any thread sealer will do.
Reply With Quote
  #144 (permalink)  
Old 04-13-2007, 07:54 PM
Stynie's Avatar
CC Member/Contributor
Visit my Photo Gallery
 
Join Date: Mar 2004
Location: Indian Trail, NC
Bike Year, Make, Engine: 80 FLH Shovel,74 93" Rigid Shovel
Posts: 1,103
Not Ranked     
After checking further........is it possible it was residual oil in the stator that came out of the windings after the engine was hot? Or maybe not. I forced air into the hole again, but heard nothing.
__________________
Reply With Quote
  #145 (permalink)  
Old 04-13-2007, 10:07 PM
Stynie's Avatar
CC Member/Contributor
Visit my Photo Gallery
 
Join Date: Mar 2004
Location: Indian Trail, NC
Bike Year, Make, Engine: 80 FLH Shovel,74 93" Rigid Shovel
Posts: 1,103
Not Ranked     
............
__________________

Last edited by Stynie; 04-14-2007 at 05:24 PM..
Reply With Quote
  #146 (permalink)  
Old 04-14-2007, 05:24 PM
Stynie's Avatar
CC Member/Contributor
Visit my Photo Gallery
 
Join Date: Mar 2004
Location: Indian Trail, NC
Bike Year, Make, Engine: 80 FLH Shovel,74 93" Rigid Shovel
Posts: 1,103
Not Ranked     
Cleaned the stator, put thread sealer on the stator screws. Took it out and rode it hard and it does not leak NO MORE!!!!
__________________
Reply With Quote
  #147 (permalink)  
Old 04-17-2007, 10:03 PM
skylarbluepuppy's Avatar
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Oct 2005
Location: bensalem, pa
Bike Year, Make, Engine: 06 pitbull
Posts: 1,357
Not Ranked     
good deal i hate leaks
Reply With Quote
  #148 (permalink)  
Old 04-17-2007, 10:47 PM
juicer's Avatar
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Dec 2003
Location: Upstate, NY
Bike Year, Make, Engine: '02 Confederate Hellcat,113S&S
Posts: 737
Not Ranked     
Thats great man, send it!!
__________________
If it ain't broke fix it 'till it is

Reply With Quote
  #149 (permalink)  
Old 04-18-2007, 01:25 AM
PART OF THE CREW FUCK OFF
Visit my Photo Gallery
 
Join Date: Feb 2006
Location: boston, ma
Bike Year, Make, Engine: 07 919
Posts: 13,682
Not Ranked     
i have to take a leak after reading this
__________________
Plasterhead 515..not the brightest bulb on the tree but the last to burn out
Reply With Quote
  #150 (permalink)  
Old 04-20-2007, 06:27 AM
BOSS's Avatar
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Mar 2004
Location: London, ON
Bike Year, Make, Engine: 05 Custom - Omen II
Posts: 2,003
Not Ranked     
mine started leaking again after having it out for a few rides and pounding on it last night....going to check my stator bolts as well now i guess.....and maybe try that vent idea......worst case....switch it to closed primary i guess.

now oil is dripping of the S&S carb cover onto the pipes as well....never had that before!
__________________
Canada's Chopper Kingpin, Customs Guru, Pimp Daddy, & all around BAD MUTHA FUCKER !!!! ~~ GETTIN' JACK'T !!

Last edited by BOSS; 04-20-2007 at 06:31 AM..
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -7. The time now is 01:15 PM.


vBulletin skins developed by: eXtremepixels
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0

CC Policy

The representations expressed are the representations and opinions of the clubchopper.com forum members and do not necessarily reflect the opinions and viewpoints of the site owners or moderators. clubchopper.com forum members agree not to post any copyrighted material unless the copyrighted material is owned by you or have been given the expressed written consent to post. Although we do not and cannot review the messages posted and are not responsible for the content of any of these messages, we reserve the right to delete any message for any reason whatsoever. You remain solely responsible for the content of your messages, and you agree to indemnify and hold us harmless with respect to any claim based upon transmission of your message(s). For full policy, please click the "CC policy" link. Thank you for visiting the clubchopper.com
Links monetized by VigLink