Club Chopper Forums ychrome  

Go Back   Club Chopper Forums > CHOPPER SHOP/TECH AREA > Shop Talk

Welcome to Club Chopper!  The World's largest and coolest place to be on the net if you dig the following!

  •  » Custom Bikes
  •  » Killer Paint
  •  » Old School Craftsmanship
  •  » Building and Wrenching
  •  » Hot Babes
  •  » Chopper Build Logs

...then you have come to the right place!

YES! I want to register an account for free right now!  p.s.: For registered members this ad will NOT show

Chopper Tech
Tech Article
Tech Article
Tech Article
Tech Article
Tech Article
Main Menu
Module Jump:
Club Chop Gallery

Club Chopper Gallery

Submit Your Photos!

Active Threads
Tappet block oil problems
Last Post: michelinesander
Posted On: 01-28-2024
Replies: 2
Views: 7,945
Powder coating
Last Post: pushrod243
Posted On: 01-15-2024
Replies: 1
Views: 7,536
revtech 100 starts then dies
Last Post: mabelhillhouse
Posted On: 01-03-2024
Replies: 1
Views: 7,142
Hello guys
Last Post: mabelhillhouse
Posted On: 01-03-2024
Replies: 0
Views: 5,189
5 speed clutch
Last Post: mabelhillhouse
Posted On: 01-03-2024
Replies: 1
Views: 7,310
More...
  #1 (permalink)  
Old 10-30-2023, 12:18 PM
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Dec 2016
Location: charleston, sc
Posts: 171
Not Ranked     
Ultima Ignition Module

All,

I have an Ultima ignition module that took a shit. It was used, so I'm not really surprised. You get what you pay for right?

I need to replace it now, and wanted to see what others thought of it. I know the Ultima knock-off carburetors, as an example, are not as tunable as the genuine S&S carbs. I have several in a box on a shelf...

The new Crane Hi-4 from S&S is outrageously expensive, and I'm trying to justify the cost, or try another Ultima.

Thanks
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 10-30-2023, 03:21 PM
CC Member/Contributor
Visit my Photo Gallery
 
Join Date: Jun 2007
Location: Upper eastern shore, MD
Bike Year, Make, Engine: 80" bobbed prostreet,'06 RdKng.
Posts: 1,648
Not Ranked     
I got 4 years out of a new hi4,but that was 17 years ago so quality might have changed since S&S acuired Crane.Been running Ultimas since.On second one now.Both times I lost hi4 and an Ultima rear cyl. lost fire when bike was at op temp.
__________________
The bearer of gossip is a small untrustworthy person who takes delight in someone else's problems. Avoid them.
Let's all make the day count. - Charlie Daniels
Reply With Quote
  #3 (permalink)  
Old 10-31-2023, 06:15 AM
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Dec 2016
Location: charleston, sc
Posts: 171
Not Ranked     
Quote:
Originally Posted by Am4wag View Post
I got 4 years out of a new hi4,but that was 17 years ago so quality might have changed since S&S acuired Crane.Been running Ultimas since.On second one now.Both times I lost hi4 and an Ultima rear cyl. lost fire when bike was at op temp.
That is exactly what is happening to my bike. Any way to prevent this in the future? I know heat is a big factor, especially the added heat from the 127.
Reply With Quote
  #4 (permalink)  
Old 10-31-2023, 05:03 PM
CC Member/Contributor
Visit my Photo Gallery
 
Join Date: Jun 2007
Location: Upper eastern shore, MD
Bike Year, Make, Engine: 80" bobbed prostreet,'06 RdKng.
Posts: 1,648
Not Ranked     
I've often pondered going to the stock setup under the cone cover and run a remote module somewhere.Til then the Ultima in there is doing fine.
__________________
The bearer of gossip is a small untrustworthy person who takes delight in someone else's problems. Avoid them.
Let's all make the day count. - Charlie Daniels
Reply With Quote
  #5 (permalink)  
Old 11-06-2023, 04:20 AM
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Dec 2016
Location: charleston, sc
Posts: 171
Not Ranked     
I may eventually do that. Replacing the pickup is easier, (and cheaper) than replacing the entire ignition.
Reply With Quote
  #6 (permalink)  
Old 11-29-2023, 11:34 AM
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Dec 2016
Location: charleston, sc
Posts: 171
Not Ranked     
Got the 127 running well, but noticed that the cam cover is VERY hot to touch. Is this to be expected? My RK does not get that hot.
Reply With Quote
Sponsored Links
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -7. The time now is 08:49 AM.


vBulletin skins developed by: eXtremepixels
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0

CC Policy

The representations expressed are the representations and opinions of the clubchopper.com forum members and do not necessarily reflect the opinions and viewpoints of the site owners or moderators. clubchopper.com forum members agree not to post any copyrighted material unless the copyrighted material is owned by you or have been given the expressed written consent to post. Although we do not and cannot review the messages posted and are not responsible for the content of any of these messages, we reserve the right to delete any message for any reason whatsoever. You remain solely responsible for the content of your messages, and you agree to indemnify and hold us harmless with respect to any claim based upon transmission of your message(s). For full policy, please click the "CC policy" link. Thank you for visiting the clubchopper.com
Links monetized by VigLink