Club Chopper Forums ychrome  

Go Back   Club Chopper Forums > CHOPPER SHOP/TECH AREA > Shop Talk

Welcome to Club Chopper!  The World's largest and coolest place to be on the net if you dig the following!

  •  » Custom Bikes
  •  » Killer Paint
  •  » Old School Craftsmanship
  •  » Building and Wrenching
  •  » Hot Babes
  •  » Chopper Build Logs

...then you have come to the right place!

YES! I want to register an account for free right now!  p.s.: For registered members this ad will NOT show

Chopper Tech
Tech Article
Tech Article
Tech Article
Tech Article
Tech Article
Main Menu
Module Jump:
Club Chop Gallery

Club Chopper Gallery

Submit Your Photos!

Active Threads
Wiring Issues, or Not?
Last Post: DeafBillyGoat
Posted On: Today
Replies: 5
Views: 96
Buell XB12 Chopper
Last Post: Poop
Posted On: Today
Replies: 24
Views: 6,878
Low miles 883 won't stay running.
Last Post: FRANKTHECRANK
Posted On: Yesterday
Replies: 6
Views: 181
Educate me on my bike
Last Post: Spade115
Posted On: 06-07-2018
Replies: 1
Views: 146
5/16-18x3" wheel adjusting bolt part number?
Last Post: IHCKoy
Posted On: 06-07-2018
Replies: 2
Views: 106
More...
  #1 (permalink)  
Old 06-02-2018, 11:46 AM
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Apr 2014
Location: East Hartford, Ct
Posts: 6
Not Ranked     
Bdl 3 inch belt drive

I'm installing a bdl 3 inch open primary on my 02 bourget low blow... . the issue in having is getting the pulleys and belt on to the shafts belt is too tight can't even get them started !! I've been in touch with bdl tech and went as far as sending them my belt and they replaced with a slightly longer one still no luck !! Any thoughts or info would be greatly appreciated !!
Thanks
Jack
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 06-02-2018, 07:05 PM
Shovel52's Avatar
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Nov 2014
Location: Shreveport, la
Bike Year, Make, Engine: 2004 Ultima Chopper
Posts: 901
Not Ranked     
I had a fight with mine too..Have you tried to barely start the belt on the front pulley, and then with the rear pulley off of the bike, barely start that one, and then shove the pulley on...then tap the belt with a hammer and a 2x4 laid across the belt to drive it home..
__________________


2004 Ultima 127 Chopper
1975 Harley Davidson Shovel head Chopper
Shreveport Louisiana

Last edited by Shovel52; 06-02-2018 at 07:10 PM..
Reply With Quote
Sponsored Links
  #3 (permalink)  
Old 06-02-2018, 07:26 PM
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Apr 2014
Location: East Hartford, Ct
Posts: 6
Not Ranked     
That's not gonna work because both pulleys have a lip on the outside side !! Thanks tho
Reply With Quote
  #4 (permalink)  
Old 06-03-2018, 07:00 PM
golfish's Avatar
Know Nothing
Visit my Photo Gallery
 
Join Date: Mar 2007
Location: Alta Loma, Ca
Bike Year, Make, Engine: 06 BBC DA...
Posts: 3,734
Not Ranked     
Quote:
Originally Posted by jackkennedy View Post
That's not gonna work because both pulleys have a lip on the outside side !! Thanks tho
It took me a little while to figure it out. I just started the front and then did the same with the rear. The lips on the pulleys has nothing to do with it.
When the belt was new I'd let it heat up in the sun for a few hrs.
__________________
There ain't nothing like a friend, that can tell you your just pissin in the wind.
Reply With Quote
  #5 (permalink)  
Old 06-04-2018, 02:04 PM
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Apr 2014
Location: East Hartford, Ct
Posts: 6
Not Ranked     
No matter what I try I can not get both pulleys started with belt attached !!?? I'm about to put back on my primo brute111 enclosed belt that assembles just fine !
Reply With Quote
  #6 (permalink)  
Old 06-04-2018, 02:12 PM
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Apr 2014
Location: East Hartford, Ct
Posts: 6
Not Ranked     
No matter what I try I can't get both pulleys started with the belt attached !!?? I think ill reinstall my primo brute111 which assembles just fine and call it a day ! Don't have time for this aggravation !!!
Reply With Quote
  #7 (permalink)  
Old 06-05-2018, 06:32 AM
STEINBVG's Avatar
Club Chopper Member
Visit my Photo Gallery
 
Join Date: May 2010
Location: ATLANTIC CITY, NJ
Bike Year, Make, Engine: 2010-14; MYSELF; 96",113",120",127"
Posts: 3,096
Not Ranked     
Quote:
Originally Posted by jackkennedy View Post
No matter what I try I can not get both pulleys started with belt attached !!?? I'm about to put back on my primo brute111 enclosed belt that assembles just fine !
I thought primo was always better
__________________
VITALY.
SORRY FOR THE UPPER CASE. I AIN'T YELLING. I JUST MAKE TOO MANY TYPOS IN THE LOWER.

113"s&s, Walz softail 2000/2012 prostreet
96"s&s, Daytec dyna/ softail hybrid, 1998/2010 chopper
127"Ultima, Chassis Design rigid 2013 bobber
120"Ultima, Kraft Tech rigid 2014 bobber
Reply With Quote
  #8 (permalink)  
Old 06-05-2018, 09:05 AM
Shovel52's Avatar
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Nov 2014
Location: Shreveport, la
Bike Year, Make, Engine: 2004 Ultima Chopper
Posts: 901
Not Ranked     
My bdl does not have a lip..Why would they start making something like that?
__________________


2004 Ultima 127 Chopper
1975 Harley Davidson Shovel head Chopper
Shreveport Louisiana
Reply With Quote
  #9 (permalink)  
Old 06-05-2018, 12:34 PM
golfish's Avatar
Know Nothing
Visit my Photo Gallery
 
Join Date: Mar 2007
Location: Alta Loma, Ca
Bike Year, Make, Engine: 06 BBC DA...
Posts: 3,734
Not Ranked     
Quote:
Originally Posted by Shovel52 View Post
My bdl does not have a lip..Why would they start making something like that?
The two 3" BDL pulleys on my Big Bear had lips (07). The custom bike I ride now has a 2" BDL, it only has a lip on the back pulley. This is also from 07.
__________________
There ain't nothing like a friend, that can tell you your just pissin in the wind.
Reply With Quote
  #10 (permalink)  
Old 06-05-2018, 03:59 PM
ecir45's Avatar
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Oct 2014
Location: New Orleans, LA
Posts: 249
Not Ranked     
pull pulley and hub install belt then put together like manual says to do a chain, worth a shot.
__________________
113" El Bruto / 5 speed
Reply With Quote
  #11 (permalink)  
Old 06-06-2018, 02:23 PM
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Apr 2014
Location: East Hartford, Ct
Posts: 6
Not Ranked     
Gave up on the bdl for now put the primo brute 111 back and install a cycle electric alternator kit while I had it apart !!! I want to ride instead of messing with that bdl !!!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -7. The time now is 10:34 PM.


vBulletin skins developed by: eXtremepixels
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0

CC Policy

The representations expressed are the representations and opinions of the clubchopper.com forum members and do not necessarily reflect the opinions and viewpoints of the site owners or moderators. clubchopper.com forum members agree not to post any copyrighted material unless the copyrighted material is owned by you or have been given the expressed written consent to post. Although we do not and cannot review the messages posted and are not responsible for the content of any of these messages, we reserve the right to delete any message for any reason whatsoever. You remain solely responsible for the content of your messages, and you agree to indemnify and hold us harmless with respect to any claim based upon transmission of your message(s). For full policy, please click the "CC policy" link. Thank you for visiting the clubchopper.com
Links monetized by VigLink