Club Chopper Forums Industrial Parts House  

Go Back   Club Chopper Forums > CHOPPER SHOP/TECH AREA > Shop Talk

Welcome to Club Chopper!  The World's largest and coolest place to be on the net if you dig the following!

  •  » Custom Bikes
  •  » Killer Paint
  •  » Old School Craftsmanship
  •  » Building and Wrenching
  •  » Hot Babes
  •  » Chopper Build Logs

...then you have come to the right place!

YES! I want to register an account for free right now!  p.s.: For registered members this ad will NOT show

Chopper Tech
Tech Article
Tech Article
Tech Article
Tech Article
Tech Article
Main Menu
Module Jump:
Club Chop Gallery

Club Chopper Gallery

Submit Your Photos!

Active Threads
Buell XB12 Chopper
Last Post: Poop
Posted On: Today
Replies: 24
Views: 6,868
Low miles 883 won't stay running.
Last Post: FRANKTHECRANK
Posted On: Yesterday
Replies: 6
Views: 178
Wiring Issues, or Not?
Last Post: EdCase
Posted On: Yesterday
Replies: 4
Views: 87
Educate me on my bike
Last Post: Spade115
Posted On: 06-07-2018
Replies: 1
Views: 142
5/16-18x3" wheel adjusting bolt part number?
Last Post: IHCKoy
Posted On: 06-07-2018
Replies: 2
Views: 103
More...
  #1 (permalink)  
Old 04-01-2018, 03:16 PM
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Apr 2011
Location: Jacksonville, NC
Bike Year, Make, Engine: 2007 ULTIMA / 1999 HARLEY
Posts: 52
Not Ranked     
Oil Dumping From Lower Vent Tube

Here lately my custom S&S 96 cu in chopper dumps oil out on the ground when trying to start it. it seems to only do it if it has been sitting awhile. Also, when trying to crank it up it does not want to turn over properly(slow) not enough to fire it up. starter terminals smoking from strain . I have checked battery and its fine/fully charged.

What could be causing this?
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 04-01-2018, 10:26 PM
golfish's Avatar
Know Nothing
Visit my Photo Gallery
 
Join Date: Mar 2007
Location: Alta Loma, Ca
Bike Year, Make, Engine: 06 BBC DA...
Posts: 3,734
Not Ranked     
Its called "sumping" .......your check valve/ball is probably dirty. Do a search on sumping, you'll find out all you need to know.

Just couriuos, what kind of oil are you using?
__________________
There ain't nothing like a friend, that can tell you your just pissin in the wind.

Last edited by golfish; 04-02-2018 at 12:43 AM..
Reply With Quote
  #3 (permalink)  
Old 05-30-2018, 03:56 PM
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Apr 2011
Location: Jacksonville, NC
Bike Year, Make, Engine: 2007 ULTIMA / 1999 HARLEY
Posts: 52
Not Ranked     
I had just some 20 50 pensoil i think . I usually run synthetic . UPDATE: I rebuilt oil pump with S&S rebuild kit. Now I still cant turn motor over. . I put two quarts in it . it is VERY hard to turn over . starter smokes from getting hot. . I pulled the plugs out and it will turn over fine. . do i have another issue. What can I do ? I cant get it to crank over enough to fire up.
Reply With Quote
Sponsored Links
  #4 (permalink)  
Old 05-30-2018, 08:09 PM
Shovel52's Avatar
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Nov 2014
Location: Shreveport, la
Bike Year, Make, Engine: 2004 Ultima Chopper
Posts: 901
Not Ranked     
If your starter is smoking from turning over slowly, I would pull it apart and look at it, if it is black inside then it is not going to last much longer..I went through that ...cleaned it twice......bought a new starter...not fun pushing that thing..
__________________


2004 Ultima 127 Chopper
1975 Harley Davidson Shovel head Chopper
Shreveport Louisiana

Last edited by Shovel52; 05-30-2018 at 08:12 PM..
Reply With Quote
  #5 (permalink)  
Old 06-05-2018, 06:00 AM
instant's Avatar
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Dec 2004
Location: TO, ON
Posts: 74
Not Ranked     
Recheck all your connections are tite and clean
Reply With Quote
  #6 (permalink)  
Old 06-05-2018, 06:03 AM
instant's Avatar
Club Chopper Member
Visit my Photo Gallery
 
Join Date: Dec 2004
Location: TO, ON
Posts: 74
Not Ranked     
Oil discharge happens to best of us. Bikes done like to sit. Oil finds its way by check valve. And gets spit out on startup. Sucks
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -7. The time now is 02:58 PM.


vBulletin skins developed by: eXtremepixels
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0

CC Policy

The representations expressed are the representations and opinions of the clubchopper.com forum members and do not necessarily reflect the opinions and viewpoints of the site owners or moderators. clubchopper.com forum members agree not to post any copyrighted material unless the copyrighted material is owned by you or have been given the expressed written consent to post. Although we do not and cannot review the messages posted and are not responsible for the content of any of these messages, we reserve the right to delete any message for any reason whatsoever. You remain solely responsible for the content of your messages, and you agree to indemnify and hold us harmless with respect to any claim based upon transmission of your message(s). For full policy, please click the "CC policy" link. Thank you for visiting the clubchopper.com
Links monetized by VigLink